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5Managing Text Flow

LESSON SKILL MATRIX

 Skill Exam Objective Objective Number

 Setting Page Layout Set margins. 3.1.1

 Working with Breaks Insert nonbreaking spaces. 3.1.2
  Add hyphenation. 3.1.3
  Remove a break. 3.1.5
  Insert a section break. 3.1.7

 Controlling Pagination Force a page break. 3.1.6

 Setting Up Columns Add columns. 3.1.4

 Inserting a Blank Page Insert a blank page into a document. 3.1.8
  into a Document 

KEY TERMS
• columns

• hyphenation

• landscape orientation

• margins

• nonbreaking spaces

• page break

• portrait orientation

• orphan

• section break

• widow
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 116 Lesson 5

As a marketing associate for First Bank, you are involved in a wide variety of mar-

keting and communications projects. In particular, you are responsible for creat-

ing and maintaining marketing collateral—brochures, posters, and other printed 

product information—that supports the sale of a product. It is time to update the 

personal Checking Choices document that your bank provides to people inter-

ested in opening new accounts. Word is a great tool for producing documents 

such as this. In this lesson, you will learn to work with page layout, control para-

graph behavior, work with section and page breaks, create and format columns, 

and insert a blank page.

SOFTWARE ORIENTATION

Page Layout Tab

The Page Layout tab contains groups of commands that will produce a formatted document’s 
layout for the entire document or sections of the document. Commands in the Page Setup 
group allow you to set margins, change the document’s orientation, and adjust the paper size for 
the entire document or sections in the document. Inserting section breaks into the document 
enables you to change the page setup for an existing section in the document without affecting 
the other pages in the document. The hyphenation command provides options to hyphenate 
words in a document automatically or manually, and the nonbreaking space wraps text to the 
next to avoid breaks at the right margin to create a uniform look.

Figure 5-1

Page Layout tab
Orientation menu Columns menu Breaks menu

Margins menu

Size menu

Page Setup groupHyphenation button

In the Paragraph group, Word contains features that control how a paragraphs breaks within 
the document and pages. You control the pagination in the document by preventing widows 
and orphans to break in the document, or keeping text together, lines together, and determining 
where page breaks will occur in the document.

You can manage the text fl ow in the document by creating multiple columns in a document, 
customize the column settings, and insert column breaks in the Page Setup group.

In the Insert tab, you can insert a blank page in the document to begin a new page.
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 Managing Text Flow 117

SETTING PAGE LAYOUT
The layout of a page helps communicate your message. Although the content of your document 
is obviously very important, having appropriate margins, page orientation, and paper size all 
contribute to the document’s readability and appearance.

Setting Margins
Margins are the blank borders that occupy the top, bottom, and sides of a document. You can 
change margins from Word’s default size of one inch using commands in the Page Setup group 
in the Page Layout tab. You can choose from a gallery or set Customize Margins in the Page 
Setup dialog box. In the Page Setup group, click the Margins menu, and a set of predefi ned mar-
gin settings are available for selection. Click the setting of your choice and the whole document 
will refl ect the changes. Click the Custom Margins command to display the Page Setup dialog 
box, where you can specify custom margin sizes. In this exercise, you customize a document’s 
margins.

The Bottom Line

WileyPLUS Extra! features an 
online tutorial of this task.

 STEP BY STEP Set Margins

GET READY. Before you begin these steps, be sure to launch Microsoft Word.

 1. OPEN the proposal fi le for this lesson.

 2. Delete the extra blank lines above USA Health Resources.

 3. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Margins menu; then choose Narrow, as shown in Figure 5-2. The margins are set 
to 0.5” from top, bottom, left, and right.

          The proposal fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

Preset margins

Opens the Page Setup 
dialog box

Figure 5-2

Margins menu
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 118 Lesson 5

5. SAVE the document in the lesson folder of your USB fl ash drive as draft_proposal.

PAUSE. LEAVE the document open to use in the next exercise.

Selecting a Page Orientation
A document’s orientation determines what direction the text extends across the page. A document in 
portrait orientation is 8 ½” � 11”, whereas a document in landscape orientation is 11” � 8½”. As 
you plan and format a document, you must choose its page orientation. In this exercise, you change a 
document’s orientation from portrait (the default) to landscape In Portrait orientation, a format 
commonly used for business documents, text extends across the shorter length of the document. 
Landscape orientation, commonly used for brochures, graphics, tables, and so on, orients text 
across the longer dimension of the page.

Figure 5-3

Page Setup dialog box

Select how margin settings are applied.

3.1.1

How do you set margins 
using the predefi ned gallery?

3.1.1

How do you customize 
margins in a document?

STEP BY STEP Select a Page Orientation

USE the document that is open from the previous exercise.

1. In the Page Setup group of the Page Layout tab, click the drop-down arrow to display 
the Orientation menu, then select Landscape, as shown in Figure 5-4. The page 
orientation changes to Landscape.

2. Click the File tab, then Print, to preview the document in Backstage view. On the right 
side of the pane, the document displays in landscape.

4. In the Page Setup group, click the drop-down arrow to display the Margins menu; 
then click Custom Margins to open the Page Setup dialog box shown in Figure 5-3. 
Change the bottom, left, and right margins to 1” and the top margin to 2”. Changing 
the margins affects all pages within the document. Click OK.
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 Managing Text Flow 119

3. SAVE document as draft1_proposal in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Choosing a Paper Size
While the standard paper size of 8½” � 11” is the default setting, Word provides several op-
tions for formatting documents for a variety of paper sizes. For instance, invitations, postcards, 
legal documents, or reports all require a different paper size. Many printers provide options for 
printing on different sizes of paper, and in some cases, you may need to change or customize the 
paper size in Word as you format your document. Legal documents, for example, must be for-
matted for 8½” � 14” paper. In this exercise, you will change the size of paper from the default.

Figure 5-4

Orientation menu

Portrait is the default orientation.

STEP BY STEP Choose a Paper Size

USE the document that is open from the previous exercise.

1. In the Page Setup group of the Page Layout tab, click the drop-down arrow to display 
the Orientation menu, then select Portrait. The orientation is changed back to portrait 
from the previous exercise.

2. From the Page Setup group of the Page Layout tab, click the drop-down arrow to display 
the Size menu, then select Legal, as shown in Figure 5-5. Word provides preset document 
sizes, or you can customize the paper size by clicking the More Paper Sizes button.

Figure 5-5

Size menu

Preset sizes for different 
types of paper

Opens the Page 
Setup dialog box.
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 120 Lesson 5

 3. On the File tab, click Print to preview your document in Backstage view. On the right 
side of the pane, the document displays in portrait orientation and legal size. It is 
good practice to preview your document before printing to ensure the text will print 
correctly.

 4. Click the Page Layout tab, then click the drop-down arrow to display the Size menu; 
next, select Letter. Notice that while in Backstage view, you can access the tabs on the 
ribbon.

 5. SAVE document as draft2_proposal in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

WORKING WITH BREAKS
Word automatically inserts page breaks in multipage documents. There may be times, however, 
when you will be working with documents that contain various objects or special layouts that 
require you to control where a page or section breaks. You can insert and remove these manual 
page breaks and section breaks, and you can control word hyphenation or set nonbreaking 
spaces in Word.

Inserting and Removing a Manual Page Break
A page break is the location in a document where one page ends and a new page begins. You 
may also decide where to insert the manual page break or set specifi c options for those page 
breaks. Page breaks display as a single dotted line with the words Page Break in the center in the 
Print Layout view (as shown in Figure 5-6). In Print Layout view, Word displays a document 
page by page, one after the other, on a blue background. In this exercise, you learn to insert and 
remove a manual page break.

The Breaks menu contains options for inserting three types of breaks:

 • Page: Inserts a manual page break where one page ends and a new page begins

 • Column: Inserts a manual column break where text will begin in the next column after the 
column break

 • Text Wrapping: Separates the text around objects on a web page, such as caption text from 
body text

STEP BY STEP Insert and Remove a Manual Page Break

USE the document that is open from the previous exercise.

 1. Delete all blank lines above Proposal Description.

 2. The insertion point is positioned before P in the Proposal Description heading.

 3. On the Insert tab, in the Pages group, click the Page Break button. A manual page 
break is inserted and the Proposal Description paragraph is forced to the next page. 
Scroll up to the fi rst page and notice the page break marker that has been inserted and 
that displays as a single dotted line, as shown in Figure 5-6.

 4. Scroll down and position the insertion point before the O in the Option 1 heading to 
insert a manual break using the Page Layout tab to force text to the next page.

 5. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Breaks menu. The Breaks menu appears, as shown in Figure 5-7.

 6. Select Page from the menu and a manual page break is inserted.

 7. Position the insertion point before the O in the Option 2 heading and repeat step 5.

 8. Position the insertion point before the O in the Option 3 heading and press Ctrl+Enter 
to enter a manual page break using the keyboard shortcut.

 9. SAVE the document as draft3_proposal in the lesson folder on your USB fl ash drive.

3.1.6

How do you force a manual 
page break?

The Bottom Line
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 Managing Text Flow 121

Page break appears 
as a single dotted 

Figure 5-6

Page Break in Print Layout View

The two types of break 
are Page breaks and 
Section Breaks.

Figure 5-7

Breaks menu
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 122 Lesson 5

 10. Scroll to the second page and notice the manual page break marker, shown in Figure 5-8.

Figure 5-8

Manual page break with hid-
den formatting marks displayed

Second page displays hidden 
marks and manual page break.

 11. On page 2, select the Page Break marker and press the Backspace key. The page break 
is deleted, and text from the previous page is moved to page 2.

 12. Scroll up to page 1, select the Page Break marker below the last paragraph in the 
Description, and press the Backspace key. The Proposal Description heading is moved 
to page 1.

 13. Select the remaining Page Break markers and press Delete.

 14. Keep the document open without saving the changes made in the last three steps.

PAUSE. LEAVE the document open to use in the next exercise.

 Another Way
 You can also 
insert a manual page break by 
 pressing Ctrl�Enter.

Click the Show/Hide  button to view page breaks and section breaks for editing purposes.

Inserting Section Breaks
A section break is used to create a layout or formatting changes in a portion of a document. 
It appears with a dotted double line, labeled Section Break. You can use section breaks to create 
a section in your document that contains a page with margins and orientation that is different 
from the remainder of the document. You can select and delete section breaks just as you can 
remove page breaks. In this exercise, you will insert a continuous section break and then change 
the margins for that section.

There are four available options for creating section breaks in Word, as shown in Table 5-1.

Take Note

Table 5-1

Types of Section Breaks
Type Description

Next Page Inserts a section break and starts the new section on the next page.

Continuous Inserts a section break and starts the new section on the same page

Even Page Inserts a section break and starts the new section on the next even-

 numbered page

Odd Page Inserts a section break and starts the new section on the next odd-

 numbered page

3.1.6

How do you delete a manual 
page break?
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 Managing Text Flow 123

STEP BY STEP Insert a Section Break

USE the document that is open from the previous exercise.

 1. Scroll up to page 1 and position the insertion point after Relocation Proposal.

 2. On the Page Layout tab, in the Page Setup group, click the Breaks menu. Then, under 
Section Breaks, select Continuous.

 3. Position the insertion point on the blank line before P in Prepared for...

 4. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Breaks menu.

 5. In the Section Breaks section of the menu, select Next Page. A section break is inserted 
in your document, as shown in Figure 5-9. Inserting a section break allows you format 
the document without affecting the other pages in the document.

Figure 5-9

Section break

Continuous section 
break displays as a 
dotted double line.

 6. Position the insertion point before the O in the Option 1 heading.

 7. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Breaks menu.

 8. Under Section Breaks, select Next Page. The Next Page break begins a new section on 
the following page.

 9. Place the insertion point on page 1 and select the three line headings to include the 
blank line below. Click the drop-down arrow to display the Page Setup dialog box.

 10. In the Margins tab, change the top margin from 2” to 1”. In the lower-left corner of the 
dialog box, notice the Apply to section displays as This section.

 11. Click the Layout tab and under the Page section, Vertical alignment, select Center, then 
click OK. The changes made in the Layout tab will be applied to this section.

 12. Click the File tab, then click Print to preview your document in Backstage view. The fi rst 
page is vertically centered, as shown in Figure 5-10, while the remaining pages are 
vertically aligned at the top with a 2” margin. Use the directional arrows in Backstage 
to go to the next page. Press the Esc key.

 13. Position the insertion point anywhere on page 3. In the Page Setup group, click the 
drop-down arrow to display the Page Setup dialog box. In the Margins tab, change the 
top margin from 2” to 1”. The margins for pages 3 and 4 are set to 1”.

 14. SAVE the document as draft4_proposal in the lesson folder on your USB fl ash drive.

3.1.7

How do you insert a next page 
section break?

3.1.5

How do you remove a section 
break?

3.1.7

How do you insert a 
continuous section break?
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 124 Lesson 5

15. Highlight and press Delete to remove each of the section breaks that you have applied.

 16. On the fi rst page, position the insertion point before the P in Prepared for. On the Page 
Layout tab, in the Page Setup group, click the drop-down arrow to display the Breaks 
menu. Under Section Breaks in the Breaks menu, select Even Page to start a new 
section on the next even-numbered page. The status bar reads 2 of 3.

17. Position the insertion point before O in Option 1 heading.

18. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Breaks menu, then select Odd Page to start a new section on the next odd-
numbered page. The status bar reads 3 of 4. Section breaks have been inserted for 
both Even and Odd Pages.

19. SAVE the document as draft5_proposal in the lesson folder on your USB fl ash drive, 
then CLOSE the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

Section breaks can be used to change types of formatting for:

 • Columns

 • Footnotes and endnotes

 • Headers and footers

 • Line numbering

 • Margins

 • Page borders

 • Page numbering

 • Paper size or orientation

 • Paper source for a printer

 • Vertical alignment of text on a page

Remember that when you delete a section break, you remove the section formatting as well.Take Note

Figure 5-10

Document with section break 
and vertical centering

Page Setup dialog box 
can be accessed through 
Backstage view.

Navigate through 
document using the 
directional arrow.

3.1.7

How do you insert an odd 
page section break?

3.1.7

How do you insert an even 
page section break?
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 Managing Text Flow 125

Using Hyphenation
Hyphens, shown as the punctuation mark -, are used to join words and separate syllables of a 
single word. By default, hyphenation is off in Word; all words appear on a single line, rather 
than hyphenated. As you format a document, however, you might need to determine when to 
apply a hyphen. In this exercise, you practice using Word’s hyphenation feature.

Note the differences here between a document with hyphenation and one without hyphenation.

Without hyphenation:

  As a marketing associate for First Bank, you are involved in a wide variety of 
marketing and communications projects.

With hyphenation:

  As a marketing associate for First Bank, you are involved in a wide variety of mark-
eting and communications projects.

STEP BY STEP Insert Hyphens in a Document

OPEN relocation_proposal from the data fi les for this lesson.

 1. On the Page Layout tab, in the Page Setup group, click the Hyphenation drop-down 
arrow and select Automatic; review your document.

2. Click the drop-down arrow to display the Hyphenation menu and select None, as 
shown in Figure 5-11.

WileyPLUS Extra! features an 
online tutorial of this task.

The relocation_
proposal fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

Figure 5-11

Hyphenation menu

Hyphenation menu

Hyphenation Options

 3. Click the Hyphenation drop-down arrow again, and select Manual. The Manual 
Hyphenation dialog box stops at the fi rst suggested text for hyphenation 
(headquarter), as shown in Figure 5-12. Click Yes. Manual Hyphenation will allow you 
to determine where to hyphenate the word by clicking Yes, No, or Cancel, and you can 
decide where to position the insertion point.

Figure 5-12

Manual Hyphenation dialog 
box

 4. Click Yes to headquarters. Click No to issue and ample. Click Yes to technology and 
location. When Word stops at transportation, move the insertion point to the third 
hyphen (after “ta”) and click Yes. Click No to proximity and Yes to business. The 
Hyphenation prompt will appear when Word has completed the process of searching 
for words to hyphenate within the document. Click OK.

 5. SAVE the document as relocation1_proposal in the lesson folder on your USB fl ash 
drive.

3.1.3

How do you apply manual 
hyphenation in a document?

3.1.3

How do you apply hyphenation 
in a document automatically?
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 126 Lesson 5

 6. Click the Hyphenation drop-down arrow and select Hyphenation Options to open the 
Hyphenation dialog box, as shown in Figure 5-13. Click the Automatically hyphenate 
document check box. Click OK.

Figure 5-13

Hyphenation dialog box
Hyphenation zone is 
the distance from the 
right margin.

Restrict the number 
of hyphens in the 
document. 

 7. Click the Hyphenation drop-down arrow and select Hyphenation Options. Then, in the 
Hyphenation dialog box, key .75” in the Hyphenation zone. The Hyphenation zone is 
the distance from the right margin in which Word is allowed to hyphenate words. The 
default is set at 0.25”. As the zone is increased, fewer words will require hyphenation.

To reduce the number of hyphens in your document, make the hyphenation zone wider. To 
reduce the raggedness of the right margin, make the hyphenation zone narrower.

 8. Click the up arrow to set the Limit Consecutive Hyphens to 2. Click OK. The number of 
hyphens in the document is restricted once the default is changed from No Limit.

 9. SAVE the document as relocation2_proposal in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

Inserting Nonbreaking Spaces
Word will determine when to wrap text to the next line as it reaches the right margin. In some in-
stances, you may want to keep the text together on the same line, such as for a date (November 19, 
20XX), a telephone number ((999) 888-5555), a proper name (LA Martinez), and so on. In this 
exercise, you learn to insert nonbreaking spaces in Word, to keep selected text on a single line.

STEP BY STEP Insert a Nonbreaking Space

 OPEN the document employment_offer_letter from the lesson folder.

 1. On the Home tab, in the Paragraph group, click the Show/Hide  button to 
display hidden marks on the page.

 2. In the fi rst paragraph of the document at the end of the second line, the month and 
day are in two separate lines.

 3. Place your insertion point after the r in November. Select the nonprinting space mark 
between “November” and “3”.

 4. Click the Insert tab, and in the Symbols group, click drop-down arrow on Symbols, 
then More Symbols to open the Symbols dialog box.

 5. Click the Special Characters tab, then select the Nonbreaking Space option in the 
Character list. Click Insert, then click Close. Inserting a nonbreaking space prevents the 
month and date from separating.

 6. SAVE the document as employment_confi rmed in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

Take Note

3.1.3

How do you change the 
hyphenation zone?

3.1.3

How do you limit hyphens?

3.1.2

How do you apply a 
nonbreaking space to a 

document?

The employment_
offer_letter fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

 Another Way
 Using the shortcut 
keys Ctrl�Shift�Space is a 
quick way to insert a nonbreak-
ing space.
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 Managing Text Flow 127

Troubleshooting  To keep text together, you must select all spaces between words and insert the nonbreaking 
space option in the Symbol dialog box.

CONTROLLING PAGINATION
A well-organized and formatted document will capture and maintain the reader’s attention.

Controlling Widows and Orphans
To maintain an appealing appearance and readable content, you may need to keep the fi rst or 
last line of a paragraph from appearing alone on the page. Word provides options for keeping 
text lines together and avoiding single lines of text at the top or bottom of a page. In this exer-
cise, you will manage Word’s Widow/Orphan Control.

A widow is the last line of a paragraph that appears at the top of a page, as shown in Figure 5-14.

The Bottom Line

Figure 5-14

A widow at the top of a page

Widow

An orphan is the fi rst line of a paragraph that appears alone at the bottom of a page, as shown 
in Figure 5-15.

Figure 5-15

An orphan at the bottom of a 
page

Orphan
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 128 Lesson 5

STEP BY STEP Turn on Widow/Orphan Control

OPEN the checking document from the data fi les for this lesson.

1. Scroll to the top of page 2 and notice the widow experience. . . at the top of the page.

 2. On page 1 of the document, select the three-line paragraph under Preferred Checking, 
including the widow.

 3. On the Home tab, in the Paragraph group, click the dialog box launcher. The Paragraph 
dialog box appears.

4. Click the Line and Page Breaks tab, as shown in Figure 5-16.

          The checking fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

 Another Way
 The Paragraph 
dialog box can be opened in 
the Page Layout tab, Paragraph 
group.

Figure 5-16

Paragraph dialog box

By default, Widow/Orphan 
Control is on.

 5. Click the check box to select Widow/Orphan Control, then click OK. Notice that another 
line of the paragraph moves to the second page. By default, Widow/Orphan Control is 
on, and in this exercise, Widow/Orphan Control was off.

 6. SAVE the document as checking_choices in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Keeping a Paragraph’s Lines on the Same Page
To keep all sentences of a paragraph on the same page, you can use Word’s Keep Lines Together 
command. By default, the Keep Lines Together feature in Word is off. To keep the lines of a 
paragraph together, select the paragraph, then open the Paragraph dialog box in the Page Layout 
tab and click to select the Keep Lines Together check box from the Line and Page Breaks tab. In 
this exercise, you will practice keeping lines together on the selected paragraph.

STEP BY STEP Keep Lines Together

USE the document that is open from the previous exercise.

 1. Select the two-line paragraph under Preferred Checking.

 2. In the Home tab, in the Paragraph group, click the dialog box launcher. The Paragraph 
dialog box appears.
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3. On the Line and Page Breaks tab, click to select the Keep Lines Together box, then click 
OK. Notice that the two lines that were at the bottom of page 1 moved to page 2.

4. SAVE the document as checking_choices2 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Keeping Two Paragraphs on the Same Page
Word considers any line of text followed by an Enter to be a paragraph. For instance, when you 
press Enter after keying a heading, the heading becomes a paragraph. To keep two paragraphs 
on the same page, you will select both paragraphs, then, in the Lines and Page Break tab of the 
Paragraph dialog box, click to select the Keep with Next check box. In this exercise, you will 
practice keeping two paragraphs together on the same page, such as a heading and the text below 
it, using Word’s Keep with Next command.

STEP BY STEP Keep Two Paragraphs on the Same Page

USE the document that is open from the previous exercise.

1. Select the Preferred Checking heading and the four-line paragraph below it.

2. On the Home tab, in the Paragraph group, click the dialog box launcher. The Paragraph 
dialog box appears.

3. On the Line and Page Breaks tab, click to select the Keep with Next box, then click OK. 
Notice that the two paragraphs (the heading and paragraph that follows) are together 
and have moved to page 2.

4. SAVE the document as checking_choices3 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Forcing a Paragraph to the Top of a Page
Automatic page breaks usually occur at acceptable places in a Word document, but there may 
be times when you need to force a paragraph to the top of a page. In this exercise, you practice 
inserting a page break before a paragraph, to force the paragraph to the top of the next page.

STEP BY STEP Force a Paragraph to the Top of a Page

USE the document that is open from the previous exercise.

1. Position the insertion point before the S in the Senior Preferred Checking heading.

2. On the Home tab, in the Paragraph group, click the dialog box launcher. The 
Paragraph dialog box appears.

3. On the Line and Page Breaks tab, click to select the Page Break Before box, then 
click OK. Using this command will force text to the top of a new page.

4. SAVE the document as checking_choices4 in the lesson folder on your USB 
fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

SETTING UP COLUMNS
Columns are vertical blocks of text in which text fl ows from the bottom of one column to the 
top of the next. Newspapers, magazines, and newsletters are formatted in columns because of 
the large amounts of text. Text formatted into columns will produce shorter lines and a white 
space between columns. By default, Word documents are formatted as single column, but you 
can change that formatting to display multiple columns or columns of varying widths.

3.1.6

How do you force a page 
break in a document?

The Bottom Line
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 130 Lesson 5

Creating Columns
In this exercise, you will practice creating columns within an existing Word document.

STEP BY STEP Create Columns

USE the document that is open from the previous exercise.

 1. Place the insertion point in front of F in Free Checking on page 1.

 2. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Columns menu. The Columns menu appears, as shown in Figure 5-17.

Figure 5-17

Columns menu

Preset columns settings

Launches the Columns 
dialog box

 3. Select Two. The text in the document following the Personal Checking Choices heading 
is formatted into two columns.

 4. SAVE the document as checking_draft in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Troubleshooting  When formatting existing text into columns, avoid selecting the document’s title heading 
if you wish to keep it as a single column.

3.1.4

How do you create columns?

Formatting Columns
In addition to Word’s common column formats, you can customize column formats to fi t the 
text and the purpose of your document. By default, when you click the Columns button and 
select from the Column menu options, the whole document is formatted as columns. Using the 
Columns dialog box, you can apply column formatting to the whole document or a selected part 
of the document, only. You also can change a document formatted in multiple columns back to 
a single-column document. In this exercise, you learn to format columns in Word.

On the Page Layout tab, in the Page Setup group, the Columns menu lists these options for 
creating common column formats:

 • One: Formats the text into a single column

 • Two: Formats the text into two even columns

 • Three: Formats the text into three even columns

 • Left: Formats the text into two unequal columns—a narrow one on the left and a wide one 
on the right
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 Managing Text Flow 131

 • Right: Formats the text into two uneven columns—a narrow one on the right and a wide 
one on the left

 • More Columns: Contains options for customizing columns

Click the Line Between box to insert a vertical line between columns.

STEP BY STEP Format Columns

USE the document that is open from the previous exercise.

 1. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Columns menu. The insertion point should be position in front of Free Checking.

 2. Select More Columns. The Columns dialog box appears, as shown in Figure 5-18.

Figure 5-18

Columns dialog box

Column width can be 
automatically set or 
adjusted manually.

Change the number 
of columns.

Preset columns options

Insert Line between 
columns.

Spacing refers to space 
between columns.

 3. In the Number of columns box, key 3 or click the up arrow once.

 4. Click the Line between check box.

 5. Click OK.

 6. Position the insertion point before the S in the Senior Preferred heading. The Page 
Break Before that was added earlier in this lesson will be removed in the next step.

 7. In the Page Layout tab, within the Paragraph group, click the dialog box launcher. In 
the Line and Page Breaks tab of the dialog box, click to deselect the Page Break Before 
box and click OK. The Page Break Before command is removed from the document 
and the text moves to the previous page. Click OK.

 8. In the Page Layout tab, change the Orientation option to Landscape and click Margins, 
then Custom Margins to open the Page Setup dialog box. Change the Top and Bottom 
margin settings to 0.5”, and in the Apply To selection box at the bottom of the Margins 
tab, notice that this will affect the Whole Document. Click OK.

 9. Place the insertion point in front of the V in Value Checking. Click the drop-down arrow 
to display the Breaks menu, then select Columns to insert a column break. Value 
Checking and the text below move to the second column.

 10. Place the insertion point in front of the P in Preferred Checking and click the drop-
down arrow to display the Breaks menu, then select Column break. Preferred Checking 
and the text below move to the third column.

 11. Place the insertion point in front of the S in Senior Preferred Checking and click the 
drop-down arrow to display the Breaks menu, then select Column. The text is moved 
to the top of the next page.

 12. Select the two headings beginning with First Bank . . . Personal Checking Choices.

 13. Click the drop-down arrow in Columns and select One. The fi rst two headings are now 
single columns.

 14. Press the Enter key after the s in Choices. Notice the Continuous Section Break 
separating the heading and the columns.

 15. Select the two headings and on the Home tab, in the Paragraph group, click the Center 
button. Applying the Center feature does not affect the text in the columns as shown 
in Figure 5-19.

How do you format columns?

3.1.4

How do you change a multiple 
column to a single column?

3.1.4

How do you insert a 
column break?

3.1.4
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 132 Lesson 5

 16. SAVE the document as checking_draft1 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Changing Column Widths
Column widths can be even or you can specify varying column widths. Word provides an op-
tion to keep the columns with the same width by selecting the Equal Column Width option. 
Column width and spacing settings are displayed for the fi rst column only and can be set to a 
specifi c width. In this exercise, you learn to change column widths in Word documents.

STEP BY STEP Change Column Widths

USE the document that is open from the previous exercise.

 1. Place your insertion point anywhere in the fi rst column.

 2. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Columns menu.

 3. Select More Columns. The Columns dialog box appears.

 4. Key 2 in the Number of Columns box or click the down arrow.

 5. Select the text in the Width box and key 3.25. Press the Tab key to move to the 
Spacing box. Notice that the spacing adjusted automatically to 2.5. Click OK. The Apply 
to section will only affect the columns.

 6. On the Page Layout tab, in the Page Setup group, click the drop-down arrow to display 
the Columns menu and select More Columns.

 7. Click the Three columns button. Select the text in the Width box and key 2.3. Press the 
Tab key to move to the Spacing box. Notice that the spacing adjusted automatically to 
1.05. Click OK.

 8. SAVE the document as checking_draft2 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

INSERTING A BLANK PAGE INTO A DOCUMENT
When creating or editing a document, you may need to insert a blank page to add more text, 
graphics, or a table. Rather than pressing the Enter key enough times to insert a blank page, Word 
provides a Blank Page command.

Inserting a Blank Page
You can insert a blank page at any point within a document—the beginning, middle, or end. To 
insert a blank page, position the insertion point and click the Blank Page command in the Pages 
group on the Insert tab. To delete a blank page, use the Show/Hide (¶) button to display hidden 

Figure 5-19

Formatted with columns

3.1.4

How do you change column 
widths?

The Bottom Line

c05ManagingTextFlow.indd Page 132  30/07/11  1:43 PM user-f396c05ManagingTextFlow.indd Page 132  30/07/11  1:43 PM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE



 Managing Text Flow 133

characters, then select and delete the page break. In this exercise, you will practice inserting a 
blank page in the middle of the document.

STEP BY STEP Insert a Blank Page

USE the document that is open from the previous exercise.

1. Position the insertion point before the F in Free Checking.

2. On the Insert tab, in the Pages group, click Blank Page (see Figure 5-20). Page 2 is a 
blank page.

Figure 5-20

Blank page

Blank Page command inserts a 
blank page at the insertion point.

3. Click the Undo  button on the Quick Access Toolbar.

 4. SAVE the document with the same fi lename in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

STOP. CLOSE Word.

3.1.8

How do you insert a blank 
page?

SKILL SUMMARY

In This Lesson, 
You Learned How To: Exam Objective Objective Number

Set page layout Set margins. 3.1.1

Work with breaks Insert nonbreaking spaces. 3.1.2
 Add hyphenation. 3.1.3
 Remove a break. 3.1.5
 Insert a section break. 3.1.7

Control pagination Force a page break. 3.1.6

Set up columns Add columns. 3.1.4

Insert a blank page Insert a blank page into 3.1.8
 into a document  a document.

Knowledge Assessment

True/False
Circle T if the statement is true or F if the statement is false.

 T F  1.  A page height that is larger than the page width is characteristic of 
portrait orientation.

 T F  2.  In Word, the default margin size is 1.5 inches for the top, bottom, left, 
and right margins.

 T F  3. Columns are blank spaces on the sides, top, and bottom of a document.

 T F  4. Paper size refers to landscape or portrait orientation.
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 134 Lesson 5

 T F  5. Widow/Orphan Control is on by default.

 T F  6. A column break moves text from one column to the next.

 T F  7.  Use Widow/Orphan Control to keep all lines of a paragraph together on 
the same page.

 T F  8. Word considers a heading a paragraph.

 T F  9. A continuous section break starts the new section on the next page.

 T F 10.  A page break is the location in a document where one page ends and a 
new page begins.

Multiple Choice
Select the best response for the following statements.

 1. What is the term for the last line of a paragraph when it is left alone at the top of a 
page?

a. Orphan

b. Widow

c. Widow/Orphan Control

d. Keep Lines Together

 2. What is the fi rst line of a paragraph that is left alone at the bottom of a page called?

a. Widow

b. Orphan

c. Widow/Orphan Control

d. Keep Paragraphs Together

 3. Pressing Ctrl+Enter produces what?

a. A section break

b. A next page break

c. A page break

d. A continuous break

 4. Which of the following is used to create layout or formatting changes in a portion of a 
document?

a. Section break

b. Page break

c. Next Page break

d. Text wrapping

 5. Which would be used to move vertical blocks of text from the bottom of one block of 
text to the top of the next block of text (on the same page)?

a. Column breaks

b. Section breaks

c. Two columns

d. Three columns

 6. Which of the following inserts an empty page at the insertion point?

a. Shift+Enter

b. Alt+Enter

c. Blank Page command

d. Page Break command

 7. Which of the following displays the Columns dialog box?

a. Columns button

b. More Columns command

c. Right-click

d. All of the above
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 Managing Text Flow 135

 8. Which of the following is used to keep two adjacent words on the same line?

a. Keep lines together

b. Keep paragraphs together

c. Nonbreaking space

d. Nonbreaking hyphen

 9. Hyphens are used to:

a. join words.

b. separate syllables.

c. break single words into one word.

d. All of the above

 10. Which of the following is true of the Manual Hyphenation command?

a. It automatically stops at a word and asks you to decide where to hyphenate.

b. It hyphenates words automatically.

c. It does not allow hyphenating on any words.

d. None of the above.

Competency Assessment

Project 5-1:  YMCA Newsletter
Format some data for the YMCA into a two-column newsletter.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN ynews from the data fi les for this lesson.

 2. Click the Show/Hide ¶  button.

 3. Position the insertion point before the M in the heading, Mother’s Day Out. . . .

 4. On the Page Layout tab, in the Page Setup group, click the Breaks button and select 
Continuous from the menu.

 5. On the Page Layout tab, in the Page Setup group, click the Columns button and select 
Two.

 6. Position the insertion point before the F in the Fall Soccer. . . heading.

 7. On the Page Layout tab, in the Page Setup group, click the Breaks button and select 
Column.

 8. On the Page Layout tab, in the Page Setup group, click the Columns button and click 
More Columns.

 9. In the Columns dialog box, click the up arrow on the Width box to change to 2.8. The 
number in the Spacing box should adjust to .9”.

 10. Click the Line Between box and click OK.

 11. Click the Show/Hide ¶  button.

 12. SAVE the document as ymca_newsletter in the lesson folder on your USB fl ash drive, 
then CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

Project 5-2:  Computer Use Policy
You are updating First Bank’s computer use policy and you need to adjust the fl ow of text on the 
page.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN computerusepolicy from the data fi les for this lesson.

         The ynews fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.

         The computer-
usepolicy fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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 2. Scroll to the top of page 3. Position the insertion point before the e in engaging in 
illegal activity.

 3. On the Home tab, in the Paragraph group, click the dialog box launcher. On the Line 
and Page Breaks tab, click to select the Widow/Orphan Control box and click OK.

 4. Position the insertion point in the last line of page 3 that begins D. Anyone obtaining. . . .

 5. On the Home tab, in the Paragraph group, click the dialog box launcher. On the Line 
and Page Breaks tab, click the Keep Lines Together box, then click OK.

 6. Position the insertion point before the S in the Section Ten heading.

 7. On the Home tab, in the Paragraph group, click the dialog box launcher. On the Line 
and Page Breaks tab, click the Page Break Before box and click OK.

 8. Place the insertion point at the beginning of the document. Click the Page Layout tab 
and in the Page Setup group, click the Hyphenation button, then click Hyphenation 
Options. Click to select the Automatically hyphenate the document check box, and 
change the Hyphenation zone setting to .50, with a consecutive hyphens limit of 3.

 9. In the fi rst page, beginning with Sample Computer Use Policy, select the hidden space 
mark after March.

 10. On the Insert tab on the Symbols group, click the Symbols button, then choose More 
Symbols. Click the Special Characters tab then select Nonbreaking Spaces. Click 
Insert, then Close. Select the nonprinting space mark before 2 in the year and press 
Ctrl+Shift+Spacebar.

 11. SAVE the document as new_computeruse_policy in the lesson folder on your USB 
fl ash drive, then CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

Profi ciency Assessment

Project 5-3:  Coffee Shop Brochure
Your supervisor at the Grand Street Coffee Shop asks you to format the information in their coffee 
menu as a brochure.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN coffeemenu from the data fi les for this lesson.

 2. Change the page orientation to Landscape.

 3. Position the insertion point before the M in the Menu heading and insert a Continuous 
section break.

 4. Create an uneven, two-column format using the Left column setting. Position the 
insertion point in front of Coffee and select text to the end of the document.

 5. Position the insertion point before the N in the Nutritional heading and insert a 
Column break.

 6. Increase the amount of space between columns to .7”. The document should fi t to one 
page.

 7. SAVE the document as coffee_shop_brochure in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

          The coffeemenu fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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Project 5-4:  Mom’s Favorite Recipes
Your mom asks you to help her create a small cookbook fi lled with her favorite recipes that she can 
share with family and friends. She has emailed you a Word document containing a few recipes to help 
you get started with creating a format.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN recipes from the data fi les for this lesson.

 2.  Position the insertion point before the C in the Chicken Pot Pie heading and insert a 
Continuous section break.

 3.  Position the insertion point before the B in the Breads heading and insert a Next Page 
section break.

 4.  Position the insertion point before the B in the Banana Nut Bread/Chocolate Chip 
Muffi ns headings and insert a Continuous section break.

 5.  Position the insertion point anywhere within the Chicken Pot Pie recipe.

 6.  Format this and the remaining recipes in the Main Dishes section into two even 
columns with .9” spacing between columns and a line between.

 7.  Position the insertion point anywhere within the Banana Nut Bread recipe.

 8.  Format this and the remaining recipes in the Breads section into two even columns 
with .9” spacing between columns and a line between.

 9.  Position the insertion point before the R in the Ranch Chicken heading and insert a 
column break.

 10. Position the insertion point before the E in the Easy Pumpkin Bread/Muffi ns heading 
and insert a column break.

 11. Position the insertion point before the C in the Chocolate Zucchini Bread heading and 
insert a column break.

 12.  Position the insertion point under Very Blueberry Coffee Cake/Muffi ns, and select the 
hidden space mark between cream cheese for the second ingredient 1/2 (8 oz) package 
of . . . and add a nonbreaking space. Click the Insert tab, in the Symbols groups, click 
More Symbols, then click the Special Character tab and select the Nonbreaking space 
option. In the ninth ingredient, select the hidden space mark between the words or 
and huckleberries, and add a nonbreaking space.

 13. Click the Show/Hide ¶  button to hide formatting marks.

 14. SAVE and the document as favorite_recipes in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

         The recipes fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.

Mastery Assessment

Project 5-5:  Threefold Bank Brochure
The Checking Choices document needs to be formatted to accommodate the whole document on 
one page. Your task is to use the features learned in this lesson and apply them to this document as 
shown in Figure 5-21.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN checkingacctchoices from the data fi les for this lesson.

 2. Reformat the document using a page size of 8½ � 14 with Landscape orientation. 
Create the brochure to look like the one shown in Figure 5-21.

 3. Remove the Next Page section break after the heading, Personal Checking Choice. 
Delete the blank line above Free Checking. Change the columns to four columns, and 
add column breaks before each column heading. After Personal Checking Choices 
apply a Spacing After to 18 pt.

          The checking-
acctchoices fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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4. SAVE the document as checking_brochure in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

PAUSE. LEAVE Word open for the next project.

Project 5-6:  Reformat the YMCA Newsletter
As an alternative to the layout you created earlier, reformat the YMCA newsletter with two uneven 
columns.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN ynewsletter from the data fi les for this lesson.

 2. Reformat the newsletter with two uneven columns using the Right column setting.

 3. Format the document on one page. (Hint: Delete the column break in the fi rst column 
and add a column break in front of Volunteer Coaches. . . .)

 4. SAVE the document as right_ymca_newsletter in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

STOP. CLOSE Word.

Figure 5-21

Checking brochure

         The ynewsletter fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

INTERNET READY

Have you considered starting your own business someday? 
Use the Internet to research small business checking accounts 

from three different banks. What are the fees? What services 
are offered? What are the restrictions? Create a three-column 
document comparing the account features of each bank side 
by side.

c05ManagingTextFlow.indd Page 138  30/07/11  1:43 PM user-f396c05ManagingTextFlow.indd Page 138  30/07/11  1:43 PM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE



 Managing Text Flow 139

CREATING COLUMNS
Visit the Student Government Association on your campus and review their marketing materials. 
Determine how you can improve the appearance of any form on fi le and incorporate the skills 
you learned in this lesson. Select a form that is a single column and apply three columns, letter 
size, landscape orientation, and other features to improve the document.

WorkplaceReady

c05ManagingTextFlow.indd Page 139  30/07/11  1:43 PM user-f396c05ManagingTextFlow.indd Page 139  30/07/11  1:43 PM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE




